Login ID  
Password  
  Terms of Use
 
Forgot Password
 
 
  Posted on 22 April 2014 : You may have heard in the news recently that a security vulnerability called “Heartbleed” was identified. This vulnerability affects the SSL communications that use the
  OpenSSL cryptographic library and puts encrypted information at risk of being stolen. You can find out more about this vulnerability at http://heartbleed.com.

   At ACE, we take the security and protection of your private information very seriously. We have reviewed our systems and would like to reassure you that we are not affected by this security
   vulnerability. However, please still remain vigilant and contact ACE at Inquiries.MY@acegroup.com should you notice anything suspicious in your transaction(s).

 
Copyright © 2011 ACE Jerneh Insurance Berhad. All Rights Reserved.
Powered by 3i-Infotech.